第一章 迅投初级功能简介 - 迅投程式化交易使用简介

第一章 迅投初级功能简介


1.1 登陆迅投 - 迅投程式化交易使用简介

1.1 登陆迅投

双击桌面上的 [image] 图标，就会弹出图1.1权限登陆界面，请输入权限用户名和密码，选择登陆。

图1.1权限登陆界面

登陆成功后将进入行情界面或上一次退出迅投时所在界面，如图1.2。

图1.2迅投登陆后行情界面


1.2 行情源选择 - 迅投程式化交易使用简介

1.2 行情源选择

用户可点击窗口右下角“迅投数据中心”图标，对行情源进行选择与设置。如图1.3。

图1.3 行情源设置与选择


1.3 补数据 - 迅投程式化交易使用简介

1.3 补数据

迅投的所有内置行情数据服务器均为全推数据，历史数据补充采取点播模式，但是动态即时行情为全推数据。如果用户初次登陆，需要先补充历史数据。点击菜单“工具→数据补充”，就会出现图1.4。

补数据步骤：

（1）单击出现数据选项下拉单，选取某一数值类型（日线、1分钟、5分钟等）；

（2）选择市场；

（3）选择数据补充范围；

（4）点“开始补充”。

1.4数据接收-补数据


1.4 界面介绍 - 迅投程式化交易使用简介

1.4 界面介绍

迅投为用户提供了以下几种软件界面：


1.4.1 行情报价表 - 迅投程式化交易使用简介

1.4.1 行情报价表

图1.5动态显示牌

（1）菜单栏

在标题栏的下方，可以看见文件、工具、画面、查看、帮助等菜单。在这里您能找到几乎所有的功能。

（2）工具栏

工具栏内包括数据补充、选项、扩展数据、导出数据、导出分笔数据、本地回放数据、数据浏览器、数据管理等选项。

（3）主窗口

选择一个品种并回车或者双击时，将进入分时视图；

在分时图回车，将进入K线图；在K线图回车，将进入分时图。

在K线或分时图中按ESC都将回到行情界面。

在主窗口中点击鼠标右键会显示一个右键菜单，迅投提供了丰富的右键菜单，在这里您可以迅速地找到在目前状态下可以使用的常见功能。

注意：在不同页面所显示出来的右键菜单是不一样的；即使在同一页面，鼠标在不同地方按右键，所弹出的菜单也有不同。

（4）选择自定义指标

在行情报价表窗口下，点击右键，菜单中包括“选择自定义指标”项，在如窗口1.6所示界面下选择相应的周期、公式名称、指标名称并确定后，可在行情报价表窗口最右增加一列自定义指标。

图1.6自定义指标


1.4.2 分时走势 - 迅投程式化交易使用简介

1.4.2 分时走势

图1.6分时走势

迅投的历史分时图走势是由历史1分钟数据生成，默认情况下只显示当日分时。迅投的分时时间的划分，与1分钟一致， 09:00:01 所表示的是09:00:00-09:00:01之间的分笔报价生成。迅投的分时图上的十字线，每次移动是1分钟的单位。


1.4.3 K线图 - 迅投程式化交易使用简介

1.4.3 K线图

迅投K线图如下图所示。点击鼠标右键，右键菜单有包括叠加指标、叠加品种、分析周期、复权处理等功能选项。

图1.7K线图


1.4.4 复制页面 - 迅投程式化交易使用简介

1.4.4 复制页面

如图1.8所示，点击“复制页面”按钮，迅投可复制出一个同样的页面，反复点击可反复复制，每个复制出来的页面均可以独立操作与拖拽

图1. 8 复制界面


1.4.4 多周期同列与多股同列 - 迅投程式化交易使用简介

1.4.4 多周期同列与多股同列

通过菜单“画面→多股同列”或““画面→多周期同列”，我们可以获得多股或/多周期同列的复合画面，复合画面中的每个分画面均可独立操作。如图1.9

图1.9 多周期同列


第二章 模型系统技术指标编写 - 迅投程式化交易使用简介

第二章 模型系统技术指标编写

迅投模型系统是一套功能强大、使用简单的计算机描述系统，可以说其它软件能做的，迅投都能做到，而且能做得更好，更贴近实战。用户可以通过期货交易所和证券交易所发送的实时行情数据和迅投决策交易系统保存的历史数据按照简单的运算法则进行分析、选股、系统测试和自动交易。

本章将讲述技术指标模型基础，编写格式、法则，公式体构成结构，编写基础技巧。


2.1 技术指标公式基础 - 迅投程式化交易使用简介

2.1 技术指标公式基础

用户只需要通过描述一个数据是如何计算的，公式系统就能将所有数据计算出来，并以曲线的形式显示出来。

模型系统以时间序列为基础，其计算对象是一组沿时间递增的数据序列，每一个时间周期包含一组数据，公式体统能对其中的任何数据进行操作。


2.1.1 模型指标公式界面内容 - 迅投程式化交易使用简介

2.1.1 模型指标公式界面内容

在启动迅投决策交易系统后，按Shift+W快捷键就会出现管理面板，下方选择模型页。

在模型栏里，单击鼠标右键，选择新建模型，将出现模型指标模型编辑器的界面，如图2.1。

2.1公式编辑器

通过该界面我们可以了解该系统的公式设定的内容和相关规则：

（1）：每一个指标公式必须有一个名称，这个名称由中文、字母和数字组成，公式名称在同类公式中必须是唯一的。

（2）：公式描述是一段文字，用来简单描述该公式的含义，在公式列表时显示这段文字，这段文字不宜过长。

（3）：该项选择定义了该指标显示的位置，是在主图上与K线叠加还是显示在副图上，一般来讲，只有少数几个主图指标会设定为主图叠加，例如MA均线、BOLL线等。

（4）：参数：计算参数用来替代公式中所需要的常数，在使用时可以方便地调节参数，不必修改公式就可以对计算方法进行调节。参数包括参数参数名、最小值、最大值、缺省值、步长五个部分，参数名称用于标识参数，计算公式时采用缺省值计算，而最小值和最大值是参数的调整范围。

（5）：其他：包括加密、快速计算、刷新间隔等内容。

（6）用法注释：模型注释是一段文字，相对于模型描述而言它可以很长，主要用来模型一个公式如何使用、注意事项、计算方法等等。

（7）：公式编辑栏，本栏为公式编辑的文本区。


2.1.2 技术指标模型编写格式和法则 - 迅投程式化交易使用简介

2.1.2 技术指标模型编写格式和法则

所有的模型系统都是遵守统一的运算法则，统一的格式进行函数之间的计算，所以我们掌握了技术指标模型的基本原理，其他的公式也不会出脱其外。

（1）数据来源

公式中的基本数据来源于接收的每日行情数据，这些数据有行情函数从数据库中按照一定的方式提取，例如，高开低收，成交量，成交额等等。

（2）数据类型

按照公式使用的数据类型，系统可以处理的数据分为两类：变量和常量。

所谓变量就是一个随着时间变化而变化的数据，例如成交量；常量就是一个永远不变的数据。每个函数需要的参数可能是变量也可能是常量，函数计算的结果一般是一个变量。

迅投指标模型的编写允许使用中文定义变量。

（3）特殊数据引用

A、指标数据引用

经常地编制公式的过程当中，需要使用另外一个指标的值，如果按照通常的做法，重新编写过这个指标显得很麻烦，因此有必要学习使用如何调用别的指标公式。

基本格式为：“指标.指标线”(参数)

a、指标和指标线之间用 .号分开，一个指标不一定只有一条指标线，所以有必要在指标后标注指标线的名称，缺失表示引用最后一条指标线。

b、参数在表达式的末尾，必须用括号括起来，参数之间用逗号分开，通过参数设置可以选择设定该指标的参数，如果参数缺失则表示使用该指标的默认参数设置。

c、整个表达式用引号引在其中，除参数以外。

例如：

“MACD.DEF”(26,12,9)表示计算MACD指标的DEA指标线，计算参数为26、12、9；

“MACD”(26,12,9)表示该指标的最后一条指标线，计算参数是26、12、9；

“MACD”表示该指标的最后一条指标线并且使用公式的默认参数。

B、跨周期引用指标数据

在迅投决策交易系统当中允许使用不同分析周期上的指标数据，并且支持与自身长短不同的任意周期引用。

a、基本格式为：“指标.指标线#周期(参数)”，格式上只是比上面指标引用多了一个周期设定其他内容和方法一样，在周期调用上存在以下对应关系：

MIN1：1分钟 MIN5：5分钟......DAY：日线 WEEK：周线 MONTH：月线 YEAR：年线

如上图所示，MIN1表示的分析周期为1分钟，那么只能是在当前周期为分笔成交图时才可以实现对该周期指标线数据的引用。例如：当前周期为日线，那么在公式中使用“MACD.DEA#WEEK”（26，12，9）表示使用了当天所在的本周的MACD指标中的数据。

b、以上格式的扩展格式为：“指标.指标线##周期”（参数），该格式比基本格式采用了不同的对齐方式，简而言之，就是说“#”的格式调用的本周期所在的上一级周期的指标数据，那么“##”的格式则表示调用了前一种格式的前一周期的指标数据，举上例而言，“MACD.DEF##WEEK”（26，12，9）表示的是从当天看来的上一周的数据，而基本格式就是当天看来的本周的数据。

关于如何使用“#”来引用其他指标周期问题的示例

1分钟K线周期，您希望调用5分钟周期K线中的收盘价（close），那么请按照下面步骤操作。

第一步：新建一个指标，命名为Y，在Y中写入下面这句代码（注意这里要不要使用冒号，否则指标线会变成赋值）：

CC:CLOSE;

第二步：新建第二个指标，命名为T，在T中写入下面代码：

AA:”Y.CC#MIN5”;

第三步：将指标“T”运行应用于盘面，您将看到软件在1分钟K线图中划出一根5分钟周期收盘价的线。

C、其他数据引用

使用以下的格式可以在当前的分析界面下引用大盘的数据或者其他个股的数据实现横向上的对比，

a、引用大盘数据引用大盘数据时使用下列函数：INDEXC/INDEXV，等等！

b、引用个股数据引用个股数据时使用下列格式：“品种代码＄数据”，在以上格式当中调用CLOSE，VOL，AMOUNT等等！例如“000002$VOL”表示000002该股本周期的成交量，“SH000001$CLOSE”同样也可以表示为上海大盘本周期的收盘价，此时的大盘被视为一只个股。


2.1.3 公式体构成结构 - 迅投程式化交易使用简介

2.1.3 公式体构成结构

A、公式语句

所有的公式体由若干语句按照一定的格式组成，每个语句表示一个计算结果，根据各个语句的功能分为两大类语句，一类是赋值语句，一类是中间表达式。

B、赋值语句

在技术指标“B:A/Z”和“C:B*0.618”就是分别两条指标线，语言间用分号隔开 。该语句被称为赋值语句，在技术指标当中，赋值语句的计算结果将会被计算机执行并形成相应的图形。每个语句可以有一个名称，该名称写在语句的最前面，并用一个冒号将它与语句分隔开。

例如：ST:MA(CLOSE,5);表示该语句求收盘价的五日均线，语句的名称为ST，在该语句后的语句中可以直接用ST来替代MA(CLOSE,5)，如：MA(ST,5)表示对收盘价的五日均线再求五日平均。

C、中间语句

一个语句如果不需要显示，可以将它定义为中间语句，例如在上例当中的第一句“A := X+Y;”，这样该语句就不会被系统辨认为是指标线了，中间语句用“:=”替代冒号，其他与一般语句完全一样，使用中间语句可以有效降低公式的书写难度，还可以将需要重复使用的语句定义成中间语句以减少计算量。

D、公式计算符

公式计算符将函数连接成为公式，计算分为算术计算符和逻辑计算符。

a、算术计算符：

包括+、-、*、/、&，它们分别对计算符两边的数据进行加减乘除计算，这同一般意义上的算术计算没有差异。 其中&为字符串相加运算。

b、逻辑计算苻

包括>、<、<>、>=、<=、=、AND、OR八种，分别表示大于、小于、不等于、大于等于、小于等于、等于、逻辑与、逻辑或运算，如果条件成立计算结果就等于1，否则等于0。“逻辑与”表示两个条件都成立时结果才成立；“逻辑或”表示两个条件中只要有一个成立结果成立。

例如：3+4=7和4>3的结果就等于1，3<=12的结果就等于0。

4>3 AND 12>=4的结果等于1，4>3 OR 3>12的结果等于1。

E、线形描述符

对于技术指标公式可以在语句加上线形描述符，用来表示如何画该语句描述的指标线。

线形描述符号包括以下7种。描述符写在语句后分号前，用逗号将它们与语句分隔开，例如在上例当中加入一句线形描述符，C:B*0.618,COLORSTICK;该语句在被执行时，会在图中添加色彩柱线，该功能在编制MACD等指标的时候会显出它的用处。

STICK：柱状线

COLORSTICK：彩色柱状线，当值为正时显示红色，否则显示绿色

COLORRED：为线形 色，RED表示红色

COLORBLUE：为线形 色，BLUE表示蓝色

COLORYELLOW：为线形 色，YELLOW表示黄色

VOLSTICK：成交量柱状线，当股价上涨时显示红色空心柱，否则绿色

LINESTICK：同时画出柱状线和指标线

LINETHICK：对线体的粗细作出描述

CROSSDOT：小叉线

CIRCLEDOT：小圆圈线

POINTDOT：小圆点线

a、COLORRED等三个线形描述符还可以自定义颜色，格式为COLOR+“BBGGRR”；BB、GG、RR表示蓝色，绿色和红色的分量，每种颜色的取值范围是00-FF，采用了16进制，例如：MA5：MA（CLOSE，5）COLOR00FFFF表示纯红色与纯绿色的混合色；COLOR808000表示淡蓝色和淡绿色的混合色。

b、LINETHICK可以允许对线型的粗细进行自定义的描述，格式“LINETHICK+（0/7）”：参数的取值范围在0-7之间，“LINETHICK0”表示最细的线，细到在图中不显示；而“LINETHICK7”表示最粗的线。

如果数值相差比较大的指标线在主图中显示，会使K线压缩成一条直线，此时一般会结合NOAXIS使用，意思是不影响坐标最高最低值。例如：A:C,LINETHICK1,NOAXIS; 输出收盘价,但不影响坐标最高最低值,用于输出到主图或叠加到其它指标上。

LINETHICK0在图表公式调试的时候会有很重要的作用，具体如下：

用户在编辑指标过程当中，避免不了进行中间调试，这涉及到遇到中间的变量在某个周期的数值等于多少。比较简单的处理方法是在公式中加语句如下：

A:B+C;

可以输出中间变量A的值，显示在图表方便直观的查看，但是有时刻意的将中间变量A输出到图表上显示会破坏图表显示格式，处理方法是在语句后加 ,LINETHICK0 控制符例如：

A:B+C,LINETHICK0;

强制只做变量在图表输出，但不做画线显示，然后用户在主图双击鼠标打开十字光标，查看A变量在指定周期的数值，进行调试。


2.2 指标公式编写基础技巧 - 迅投程式化交易使用简介

2.2 指标公式编写基础技巧

在公式选择器中。用鼠标右键点“技术指标”，选择“新建公式”，就会出现图2.2指标公式编辑器:

2.2指标公式编辑器

我们就可以开始编模型了。

我们将通过一个例子为大家展示模型编辑的基本用法。

下边的例子是一个股指期货基差计算模型，将其应用在一分钟K线上，通过算数计算与跨周期引用，即可求得股指期货当月、隔月、下季合约的基差。

模型程序示例及注释如下：

hs300cc:=callstock('sh000300',vtclose,1,0); //取得HS300一分钟K线上本周期收盘价

hsif0:=callstock('ifl0',vtclose,1,0); //取得IF当月合约一分钟K线上本周期收盘价

hsif1:=callstock('ifl1',vtclose,1,0); //取得IF下月合约一分钟K线上本周期收盘价

hsif2:=callstock('ifl2',vtclose,1,0); //取得IF下季合约一分钟K线上本周期收盘价

Q1_x:hsif0-hs300cc; //取得IF当月合约基差

Q2_x:hsif1-hs300cc; //取得IF下月合约基差

Q3_x:hsif2-hs300cc; //取得IF下季合约基差

在编辑好以上程序后，点击“编译”，待显示“编译成功”后，点击“应用于图”，即

可可将以上指标显示在所应用的K线图下，如图2.3。

图2.3模型指标显示


第三章 模型回测与下单 - 迅投程式化交易使用简介

第三章 模型回测与下单

迅投提供一整套开放的回测系统，用户既可以直接使用也可以在充分了解其原理后进行自行修改。以下我们将通过一个简单的例子讲述迅投回测系统的原理与使用方法。

例：我们将在IF00合约1分钟K线图下计算5分钟均线与30分钟均线值，若5分钟均线上穿30分钟均线即发出开多信号，而5分钟均线下穿30分钟均线即发出平多信号。相应的程序如下：

BK1:=0;

SP1:=0;

SK1:=0;

BP1:=0; //开平仓信号每周期置零

MA5：=MA(CLOSE,5);

MA30：=MA(CLOSE,30); //计算5周期均线与30周期均线

if cross(MA5,MA30) THEN BEGIN

BK1 :=1;

END //确定开多信号

if cross(MA30,MA5) THEN BEGIN

SP1:=1;

END //确定平多信号

用户如果需要用其他条件确定开平仓信号，可也仿照以上程序进行修改。

在开平仓信号确定后，跟一段迅投提供的回测系统程序，即可进行回测，回测示例在迅投中自带有完整范例。

如图3.1将开平仓代码与回测代码合并后，经过编译、应用与图，即可在副图上获得回测指标：

3.1 模型编写与回测

如图3.2模型应用于图后，在附图上我们对应K线，即可方便的获得每一个开平仓点，以及每一根K线所对应的回测指标。

图3.2图形回测界面

与模型回测相似，迅投也提供可开放编辑的下单程序给用户使用，用户仅需要将该程序附在其买卖点确认与回测程序之后并设置相应的账户、品种、下单方式等信息即可，通过该程序用户可以实现对迅投交易端软件进行实时下单，下单示例在迅投中自带有完整范例。


第四章 参数优化 - 迅投程式化交易使用简介

第四章 参数优化

迅投亦提供方便易用的参赛优化功能。我们同样以上一章所用的均线穿越为例，如图4.1所示：

图4.1参数优化

我们仅需将原有程序中所需优化的参数更改为P1、P2，并在“参数”中设置其“参数名”、“缺省”、“最小”、“最大”、“步长”等值，点击“公式测评”选择需测评的公式、品种、周期、指标等参数，点击“优化”即可进行参数优化。在这个例子中我们使用P1、P2两个参数，优化“盈亏”指标，优化结果如下图所示：

图4.2优化结果


第五章 组合模型 - 迅投程式化交易使用简介

第五章 组合模型

迅投具备强大的组合模型编写与回测功能，

组合模型主要分为母模型和子模型两部分，其中子模型与单股模型相似，用户只要简单编写买卖条件，我们就可以根据模型框架向母模型计算输出买卖信息，子模型向母模型信号输出部分程序 迅投中自带有完整范例。子模型编辑窗口如下图:

图5.1组合模型子模型编辑

而母模型主要承担图股票篮子管理与综合收益计算等功能，在母模型里，我们仅需要设置股票篮子里的股票品种以及对应的子模型名称，即可完成整个组合模型的运行。 无论子模型和母模型的框架，我们也都是可以开放修改的。 下图为母模型编辑窗口。

图5.2 组合模型母模型编辑

编译母模型并，在指数K线下运行母模型即可类似单股模型，获得回测指标曲线，在回测指标曲线上点击其右键菜单，可获得组合模型的持仓面板，通过在K线下移动鼠标，可以观察到任何一条K线上模型的持仓情况，如果在交易过程中将最后一根K线的持仓信息发送到迅投交易软件上，即可进行组合模型的自动交易。回测界面与持仓面板如下图所示：

图5.3 组合模型回测界面与持仓面板


快捷键总汇 - 迅投程式化交易使用简介

快捷键总汇

F3 上证指数分时图

F4 深圳成指分时图

F5 分时图、K线图切换

F6 沪深A股行情列表界面

F8 切换K线分析周期

F10 查看指数成分股

Ctrl+O 弹出指标叠加对话框

Ctrl+Z 添加自选股

Ctrl+M 多股同列

Ctrl+X 多周期同列（在K线界面下使用）

Ctrl+R 系统切换至光标所指日期（在K线界面下使用）

Ctrl+V 不复权/前复权切换

Ctrl+B 不复权/后复权切换

SHIFT +Q 弹出变量查看器（模型条件下）

SHIFT+G 弹出持仓面板（组合模型条件下）

SHIFT +L 锁定界面位置

SHIFT +W 弹出/关闭管理面板

SHIFT +I

HOME 光标移至最左

END 光标移至最右

Insert 添加自选股

下列快捷键是由键盘精灵输入

60 全部A股涨幅

61 沪A涨幅排名

62 沪B涨幅排名

63 深A涨幅排名

64 深B涨幅排名

65 沪债涨幅排名

66 深债涨幅排名

67 深泸A涨幅排名

68 深泸B涨幅排名

69 中小企业涨幅排名